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Chapter 1 - VPN 

How to  Configure Site -to-site IPSec VPN Where the Peer has a 

Static IP Address  
 

This example shows how to use the VPN Setup Wizard to create a site -to -site VPN with 

the Peer has a Static IP Address. The example instructs how to configure the VPN tunnel 

between each site. When the VPN tunnel is configured, each site can be accessed 

securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site -to -

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next . 
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP address of th e network connected to the gateway  and 

Remote Subnet to be the IP address of the netw ork connected to the peer gate way . 
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for Branch  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site -to -

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next . 
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP addres s of the network connected to the gateway  and 

Remote Subnet to be the IP address of the netwo rk connected to the peer gateway.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a summar y of the VPN tunnel. You can Edit it if you want to modify.  
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Test IPSec VPN Tunnel 

VPN Status > IPSec VPN 

Verify the IPSec VPN status . 

 

 

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1  
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How to  Configure Site -to-site IPSec  VPN Where the Peer has a 

Dynamic  IP Address  
 

This example shows how to use the VPN Setup Wizard to create a site -to -site VPN with 

the Peer has a Dynamic IP Address. The example instructs how to configure the VPN 

tunnel between each site. When the VPN tu nnel is configured, each site can be 

accessed securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Custom. 

Click Next . 

 

 

VPN > Site to Site VPN  

Type My Address and select Peer Gateway Address as Dynamic Address.  Type a secure 

Pre-shared key.  

 



 

Copyright ©  202 5 Zyxel and/or its affiliates. All rights reserved . 19 
 

www.zyxel.com  

Scroll down to find the Phase2 setting. Type Local and Remote Subnet and select 

Responder Only. Then click save change.  
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Set up IPSec VPN Tunnel for Branch  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Custom. 

Click Next.  

 

 

VPN > Site to Site VPN  

Type My Address as 0.0.0.0 and type Peer Gateway Address.  Type a secure Pre -shared 

key.  
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Scroll down to find the Phase2 setting, type Local and Remote Subnet. Then click save 

change.  
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Test IPSec VPN Tunnel 

VPN Status > IPSec VPN 

Verify the IPSec VPN status . 

 

 

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160 .1 
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How to  Configure IPSec Site to Site VPN while one Site is behind 

a NAT router  
 

This example shows how to use the VPN Setup Wizard to create a IPSec Site to Site V PN 

tunnel between USG FLEX H  devices. The example instructs how to configure t he VPN 

tunnel between each site while one Site is behind a NAT router. When the IPSec Site to 

Site VPN tunnel is configured, each site can be accessed securely.  

 

 

 

 

 

 

 

 

 

 

 

Note: Please ensure that you have NAT mapping UDP port 4500 to USG  FLEX H 

device.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN nam e used to identify this VPN connection. Select the Behind NAT to the 

Remote Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > A uthentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP address of th e network connected to the gateway  and 

Remote Subnet to be t he IP address of the netw ork connected to the peer gateway . 
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for Branch  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the Behind NAT to the 

Local Site. Click Next.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Copyright ©  202 5 Zyxel and/or its affiliates. All rights reserved . 30 
 

www.zyxel.com  

VPN > Site to Site VPN > Scenario > Network   

Configur e My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network  > Authentication  > Policy & Routing   

Set Local Subnet to be the IP address of th e network connected to the gateway  and 

Remote Subnet to be the  IP address of the netw ork connected to the peer gateway . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Copyright ©  202 5 Zyxel and/or its affiliates. All rights reserved . 32 
 

www.zyxel.com  

VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network  > Authentication  > Policy & Routing  > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Test IPSec VPN Tunnel 

VPN Status > IPSec VPN 

Verify the IPSec VPN status . 

 

 

Ping the PC in Branch Office  

Win 11 > cmd > p ing 192.168.160.1  
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How to Configure Remote  Access VPN with Zyxel VPN Client  

This guide provides step -by -step instructions to set up Remote Access VPN on Zyxel USG 

FLEX H series devices using SSL VPN and IKEv2 VPN, with the new SecuExtender VPN  

Client. Itõs intended for IT administrators and support teams deploying secure remote 

access globally.  
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Before You Begin  

1. Create a Local User for VPN Authentication  

Navigate to User & Authentication > User/Group > User  

Create a local user account for  remote access authentication.  

 ̧ Enter a username and password.  

 ̧ Save the settings.  
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2. Download and Install the Latest SecuExtender VPN Client  

You can download it from the device GUI or from the Zyxel official website . 

Download Link   

  

 

After installation, desktop shortcut icons will appear:  

   

 

Configure SSL VPN on the Device   

1. Navigate to  VPN > SSL VPN 

2. Enable SSL VPN 

3. Select the incoming interface  (e.g., ge1(WAN)  or ge4 (LAN)  ).  

4. Choose the Port (D efault port : 10443 ). 

5. Choose the tunnel type  based on your network policy :  

 ̧ Internet and Local Network s (Full Tunnel): All traffic goes through VPN   

 ̧ Local Network s Only  (Split Tunnel ): Only specified subnet(s) go through VPN  

6. Define which internal network(s) VPN users can access.  

 ̧ Example: Allow access to 192.168.100.0/24  

ʤ Add to Local Networks : 192.168.100.0/24  

7. The default address pool for SSL VPN is 192.168.51.0/24  

8. Assign allowe d users for SSL VPN access 

* This SSL VPN configuration is also compatible with standard OpenVPN clients. You can 

download the .ovpn  file from the device and import it into an OpenVPN client to 

establish a connection.   

https://www.zyxel.com/global/en/products/endpoint-and-connectivity/ipsec-and-ssl-vpn-client-secuextender-vpn-client
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Configure IKEv2 VPN on the Devi ce   

1. Navigate to VPN > IPSec VPN > Remote Access VPN  

2. Enable IPSev VPN 

3. Select the incoming interface  (e.g., ge1(WAN)  or ge4 (LAN)  ) 

4. Choose the tunnel type  based on your network policy:  

 ̧ Internet and Local Networks (Full Tunnel) : All traffic goes through VPN  
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 ̧ Local Networks Only (Split Tunnel) : Only specified subnet(s) go through VPN  

5. Define which internal network(s) VPN users can access.  

 ̧ Example: Allow access to 192.168.100.0/24  

ʤ Add to Local Network : 192.168.100.0/24  

6. The default address pool for IKEv2 VPN is 192.168.50.0/24  

7. Assign allowed users for IKEv2 VPN access  

 

 

 

 

 

 

Note: When configuring IKEv2 VPN for use with the Windows (Native IKEv2 

Client)  and selecting Interface as the incoming interface, you must enter the 

domain name  (as shown in the certificate) in the NAT Traversal field.  

This allows the Windows client to correctly establish the VPN tunnel using the 

domain name instead of the IP address. (see Self-Signed Certificate Scenario (For 

Windows Native IKEv2 Client)  
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Set Up Remote Access on SecuExtender VPN Client  

The new SecuExtender VPN Client combines SSL VPN and IKEv2 VPN in a single 

application, eliminating the need for separate software . 

1. Launch t he client  

 

2. Navigate to Menu  > Configuration  > Get from Server  
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3. Enter the Gateway Address , Username , and Password  

4. Click Next  to fetch the VPN configuration file  

 

5. Both SSL VPN and IKEv2 settings will be available.  
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Test SSL VPN Tunnel on SecuExten der VPN Client  

1. Launch the SecuExtender VPN Client  

2. Right-click the VPN profile and òOpen Tunnel ó and log in. 

  

3. Once connected, the profile status will turn green, indicating an active tunnel.  
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4. You should now be able to access internal network resources.  

  
 

Test IKEv2 VPN Tunnel on SecuExtender VPN Client  

1. Launch the SecuExtender VPN Client  

2. Right-click the VPN profile and òOpen Tunnel ó and log in. 
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3. Once connected, the profile status will turn green, indicating an active tunnel.  

4. You should now be able to a ccess internal network resources.  

 

 

Set Up IKEv2 VPN On Windows (Native IKEv2 Client)  

1. Download the VPN configuration script  from the USG FLEX H web configurator.  

 

2. Run the script ( .bat  file) and enter your credentials when prompted . 
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3. VPN will connect an d access internal resources  
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Set Up IKEv2 VPN on iOS 

1. Download the iOS/macOS VPN configuration script  from the USG FLEX H web 

configurator . 

 

2. Send it to the iOS/macOS device . 

3. Go to Settings  > Profile Downloaded , then Install  

(Mac device:  System Settings > Network / VPN  ) 
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4. Enter your username and password . 

  
5. Connect to the VPN from the Settings  > VPN menu.  
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Set Up IKEv2 VPN on Android (strongSwan App)  

1. Download the Android VPN configuration script  from the USG FLEX H web configurator . 

 

2. Install the  strongSwan  VPN Client  from Google Play  Store 
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3. Send the config script to the  Android  device.  

4. Import the profile into strongSwan  

 
5. Connect to the VPN using your credentials  

 



 

Copyright ©  202 5 Zyxel and/or its affiliates. All rights reserved . 50 
 

www.zyxel.com  

 

Set Up OpenVPN Client  

1. Download and install the OpenVPN Connect  client from th e OpenVPN official website or app 

store.  

 

2. Download the SSL VPN configuration script  from the USG FLEX H web configurator at VPN > SSL 

VPN 

  
3. Import the .ovpn  file into the OpenVPN client  
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4. Once connected, you can access internal resources.  

 

 

 

Configur ing Split Routing for OpenVPN  Connect Client  

When the USG FLEX H is configured for Full Tunnel but you need Split Tunnel for specific clients, you 

can configure different split route settings by modifying the SSL VPN configuration file (.ovpn). This 

docume nt explains the process:  

1. Download the SSL VPN configuration file (.ovpn) from the USG FLEX H.  
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2. Open the .ovpn file in a text editor.  

 

 

3. Modify the file to enable split routing : 

a.  Remove the redirect -gateway  line to disable full routing.  

 

b.  Add route -nopull  to prevent pulling routes from the  SSL VPN server. 

c.  Add specific routes, e.g., route 192.168.168.0/24  and route 192.168.169.0/24  

Add split routes  

Č Add òroute 192.168.168.0 255.255.255.0ó 

Č Add òroute 192.168.169.0 255.255.255.0ó 
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Troubleshooting Self -Signed Certificates with Native Windows VPN 

Client  

If using a self -signed certificate with a domain name and the incoming interface set to òInterfaceó, 

you may encounter connection issues. Follow these steps to configure NAT Traversal to resolve this:  

 

Conditio ns 

(1) Incoming Interface set to òInterface ó. 

(2) The self-signed  certificate subject name  (Certificate for VPN Validation)  set as a 

òdomain name ó. (e.g., cherryworker.com)  
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Solution: Configure NAT Traversal  

(1) Log in to the USG FLEX H management interface.  

(2) Navigate  to VPN > IPSec VPN > Remote Access VPN . 

(3) Locate the NAT Traversal settings.  

(4) Set the NAT Traversal field to the same domain name as the certificate (e.g., 

cherryworker.com).  

(5) Save the settings.  

(6) Download the updated Windows VPN configuration script from the U SG FLEX H web 

configurator.  

(7) The script will automatically use the domain name (e.g., cherryworker.com) instead 

of an IP address for the òServerAddressó.  

(8) The VPN should connect without manual changes to the script.  

This ensures proper script generation and  prevents connection failure.  

More info: Microsoft Troubleshooting Guide . ( https://learn.microsoft.com/en -

us/troubleshoot/windows -server/networking/troubleshoot -always -on -vpn ) 

 

https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/troubleshoot-always-on-vpn
https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/troubleshoot-always-on-vpn
https://learn.microsoft.com/en-us/troubleshoot/windows-server/networking/troubleshoot-always-on-vpn
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Script  of òServerAddressó. 
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How to  Configure Site-to-site IPSec VPN between ZLD and uOS 

device  
 

This example shows how to use the VPN Setup Wizard to create a site -to -site VPN with 

the Peer gateway is ZLD device. The example instructs how to configure the VPN tunnel 

between each site. When the VPN tunnel is configured, each site can be accessed 

securely.  
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Set up IPSec VPN Tunnel for uOS 

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site -to -

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Co nfigure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP address of the netw ork connected to USG FLEX H and 

Remote Subnet to be the IP address of the netw ork connected to the peer ZyWALL . 
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for ZLD 

VPN > IPSec VPN > VPN Gateway  

Select the WAN interface and type the Peer Gateway Address.  
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Type Pre-shared Key. The default proposal which created by wizard is 

òEncryption:AES128, Authentication:SHA1, Key Group:DH2ó. Those are the same as uOS. 
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VPN > IPSec VPN > VPN Connection  

Select VPN Gateway and set Local Subnet to  be the IP address of th e network 

connected to be ZyWALL  and Remote Subnet to be the IP address of the netw ork 

connected to the peer USG FLEX H . 
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The default proposal which created by wizard is òEncryption: AES128, Authentication:  

SHA1, Key Group:  DH2ó. Those are the same as uOS. 
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Test IPSec VPN Tunnel 

VPN Status > IPSec VPN 

Verify the IPSec VPN status  on uOS device.  

 

 

Ping the PC that is connected to ZLD device  

Win 11 > cmd > ping 192.168.2.34  
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How to Configure Route -Based VPN 

This example shows how to use the VPN Setup Wizard to create a site -to -site VPN with 

the Peer has a Static IP Address. The example instructs how to configure the VPN tunnel 

between each site. When the VPN tunnel is configured, eac h site can be accessed 

securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site -to -

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set  Type to Route -Based and configure the Remote Subnet.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a summary of the  VPN tunnel. You can Edit it if you want to modify . 
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Set up IPSec VPN Tunnel for Branch  
VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site -to -

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set  Type to Route -Based and Remote Subnet.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a sum mary of the VPN tunnel. You can Edit it if you want to modify . 
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Test IPSec VPN Tunnel 

VPN Status > IPSec VPN  

Verify the IPSec VPN status.  

 

 

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1  
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How to Use Tailscale  
 

Whatõs Tailscale?  

Tailscale is a secure, peer -to -peer VPN solution that simplifies connecting devices over the 

internet. Unlike traditional VPNs, Tailscale establishes direct connections between devices 

without requiring complex firewall configurations or static IP addresses. It uses a mesh 

network topology, allowing every device to communicate directly with every other 

device securely.  

 

Start to Tailscale and implement on Firewall  

1. Please refer TailScale KB to create an account and start . 

2. Navigate to òSettings -> Personal Settings -> Keysó and òGenerate auth keyó. 

 

 

 

 

 

 

https://tailscale.com/kb/1017/install
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3. Give a Description Name as you want and disable òReusableó due to security reason 

then click òGenerate keyó. 
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Copy the key.  

 

4. Login Firewall and navigate to òVPN -> Tailscaleó, paste to the òAuth Keysó. 

 

 

 

 

Note:  

 

 

 

 

 

 

Note:  

· When you want to change the key, please click Logout.  

· You can choose the zone by yourself. We recommend using Tailscale zone 

for some predefined rules.  
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5. Go back to the Tailscale admin page. Y ou will see the Firewall device.  

 

Click òDisable key expiryó for all client to prevent lost connection while expire. 
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Scenario  

We have two subnets, 192.168.168.0/24 and 192.168.160.0/24, which are located 

behind firewalls. Both the firewalls and the Client A are part of the Tailscale VPN 

network.  The objectives are as follows:  
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Case1: Allow Client A to access the 192.168.168.0/ 24 and 192.168.160.0/24 subnets  

1. Advertised 192.168.168.0/24 in Firewall A.  

 

2. Advertised 192.168.160.0/24 in Firewall B.  
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3. Ensure Both subnets have been approved from Tailscale portal.  

 

Test the Result 

Now, Client A know how to rout e traffic and able to access 192.168.168.1 and 

192.168.160.1. 
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Case  2: Allow Client A to access internet through Firewall  

1. Take Firewall A as example. Enable òExit Nodeó and òDefault SNATó. 
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2. Ensure the Exit-Node have been enabled from Tail scale portal.  
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3. Client A need to select Firewall A as exit node.  

 

 

Test the Result 

The internet traffic will send to Firewall A.  
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Case3: The devices within the 192.168.168.0/24 and 192.168.160.0/24 subnets can 

communicate with each other  

Onc e you completed advertised Networks, you can communicate each other.  

 

Test the Result 

The ping test from Firewall A  

 

The ping test from Firewall B  
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Chapter 2 - Security Service  

How to Block HTTPS Websites Using Content Filtering and SSL 

Inspection  

This is an example of using a FLEX Content Filtering, SSL Inspection and Security Policy to 

block access to malicious or not business -related websites.  

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Set Up Content Filter  

Go to Security Service > Content Filtering . Click Add to create a content f iltering profile 

in Profile Management.  

 

Type  profile name and enable log for block action in General Settings.  

 

Tick Streaming Media category  in Managed Categories , and click Apply.  
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Set Up SSL Inspection  

In the FLEX, go to Security Service > S SL inspection > profile  > Profile Management , and 

click Add to create profile  

 

Type profile Name, and select the CA Certificate to be the certificate us ed in this 

profile.  Leave other actions as default settings.   

 

Click Apply to add SSL Inspection profi le. 
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Set Up the Security Policy  

Go to Security Policy > Policy control. Edit LAN_Outgoing , and scroll down to profile 

section.  

Select Content Filtering, and SSL Inspection. Click Apply to save.  

 

Export Certificate from FLEX and Import it to Windows  

 
When SSL inspection is enabled and an access website does not trust the FLEX 

certificate, the browser will display a warning page of security certificate problems.  

Go to System > Certificate > My Certificates  to export default certificate from FLEX.  

 

 

Click Export Certificate  to export certificate file, and Save default certificate as 

default .crt  file to Windows OS.  
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In Windows  Start Menu > Search Box , type MMC and press Enter. 

 

In the mmc console window, click  File > Add/Remove Snap -in...  

 

In the Available snap -ins, select the Certificates  and click Add  button. Select Computer 

account  > Local Computer . Then, click Finished and OK to close the Snap -ins window.  
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In the mmc console window, open the Certificates (Local Computer) > Trusted Root 

Certi fication Authorities, right click  Certificate > All Tasks > Importé 

 

Click  Next . Then, Browse..., and  locate the default .crt  file you downloaded earlier. Then, 

click Next . 
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Select  Place all certificates in the following store  and then click Browse and find Trusted 

Root Certification Authorities.  Click Next , then click  Finish. 
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Test the Result 

Using Web Browser to access the YouTube . The gateway will redirect you to a blocked 

page.  

 

Go to Log & Report > Log/Events and select Content Fil tering  to check the logs.  
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Go to Security Statistics > SSL Inspection > Summary. Traffic is inspected by SSL 

inspection.  

 

Go to Security Statistics > Content Filter  to check summary of all events.  
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How to Configure Content Filter with HTTPs Domain Filter                    

The Content Filter with HTTPs Domain Filter allows you to block HTTPs websites by 

category service. The filtering feature is based on over 100 categories that is built in 

USG Flex H such as pornography, gambling, hacking, etc.  

Whe n the user makes an HTTPS request, the information contains a Server Name 

Indication (SNI) extension fields in server FQDN. Using the SNI to query category from 

local cache then the cloud database, then take action when it matches the block 

category in the  Content Filter profile.  

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 

1.10). 
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Set Up the Content Filter  

Go to Security Service > Content Filtering > Profile Management   > Add  a Content Filter 

profile . Configure a Name for you to identify the Content Filter profile such as 

òSocial_Networkingó. Confi gure the Action  to block when the Content Filter detects 

events.   

  

Navigate  to Test Web Site Category  and type URL to test the category and click Query . 
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You will see the category recorded in the external content filter serverõs database for 

both HTTP and HTTPS Domain you specified.  

 

Scroll to the Managed Categories section, and select categories in this section to 

control access to specific types of Internet content.  
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Set Up the Security Policy  

Go to Security Policy > Policy Control  to configure a Name  for you to identify the 

Security Policy  profile. For From and To policies, select the direction of travel of packets 

to which the policy applies and apply the Profile > Content Filter  òSocial_Networking ó on 

this security policy.  
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Test Result 

Type the URL http:// www.facebook.com / or https:// www.  facebook .com / onto the 

browser  and cannot browse facebook . 

 

Navigate  to Log & Report  > Log / Events , you will  see [alert] log of blocked messages .  

 

 

 

 

 

 

 

 

 

 

http://www.facebook.com/
http://www.youtube.com/
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How to Block Facebook Using a Content Filter Block List                     

This is an example of using USG Flex H UTM Profile in a Security Policy to block access to 

a specific social network service. You can use Content Filter and Policy Control to 

make sure that a certain web page cannot be accessed through both HTTP and HTTPS 

protocols.  

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG F LEX 500H (Firmware Version: uOS 1.10). 
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Set Up the Content Filter  

In the USG Flex H, go to Security Service > Content Filtering > Profile Manageme nt  > 

Add  a Content Filter profile . Configure a Name for you to identify the Content Filter 

profile such as òFacebook_Blockó. Configure the Action  to block when the Content 

Filter detects events.   

  

 

Go to Block List  and type URL ò*.facebook*.comó to add the URL that you want to 

block . 
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Set Up the Security Policy  

Go to Security Policy > Policy Control  to configure a Name  for you to identify the 

Security Policy  profile. For From and To policies, select the direction of travel of packets 

to which t he policy applies and apply the Profile > Content Filter  òFacebook_Block ó on 

this security policy.  
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Test the Result 

Type the URL http:// www.facebook.com / or https:// ww w.  facebook .com / onto the 

browser  and cannot browse facebook . 

 

Go to Log & Report  > Log / Events , you will see [alert] log of blocked messages . 

 

  

 

 

 

 

 

 

 

 

 

http://www.facebook.com/
http://www.youtube.com/
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How to block YouTube access by Schedule                    

This is an example of using the USG Fl ex H to block access YouTube access by schedule. 

You can use Application Patrol and security policy with schedule settings to make sure 

that YouTube cannot be accessed in your network at a specific prohibited time. This 

article will guide you on how to dep loy it.  

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware  Version: uOS 1.10).  
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Set Up the Schedule  

Go to Object > Schedule > Recurring >  Add  Schedule Recurring Rule . Configure a 

Name for you to identify the Schedule Recurring Rule . Specify the Day Time  hour and 

minute when the schedule begins and end s each day.   
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Create  the Application Patrol profile  

In the USG Flex H, go to  Security Service > App Patrol > General Settings > Application 

Management . To add an App Patrol profile, configure the profile name and select 

òSearch Application ó. Then enter the keyword òyoutubeó to search the key-related 

results and select all YouTube -related apps and click Add.  
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Set Up the Security Policy  

Go to  Object > Service  to add a UDP 443 service object.   
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Go to Security Policy > Policy Co ntrol  to configure a Name  for you to identify the 

Security Policy  profile. For From and To policies, select the direction of travel of packets 

to which the policy applies. Select the service  QUIC_UDP443 and select the Schedule  

that defines when the policy would be applied.  

In this example, select òYoutube_Blocked_Timeó.  
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Add another security policy to block YouTube by schedule. To configure a Name  and 

the From, To traffic direction. Select the Schedule  that defines when the policy would 

be applied.  Finally, to scroll down the Profile , check Application Patrol  and select a 

profile from the list box. In this example, Schedule : Youtube_Block_Time; Application 

Patrol : Youtube.  
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Then go back to the security policy page and move the security priority  of block UDP 

443 is higher than block YouTube by schedule.  
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Test the Result 

Type the URL http:// www.youtube.com / or https:// www.youtube.com / onto  the 

browser  and cannot browse YouT ube . 

 

Open the YouT ube APP on the phone  and cannot access to YouT ube . 

 

 

http://www.youtube.com/
http://www.youtube.com/
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Go to Log & Report  > Log / Events , you will see [alert] log of blocked messages .  
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How to Control Access to Google Drive  
 

This is an example of using a FLEX UTM Profile in a Security Policy to block access to a 

specific file transfer service. You can use Application Patrol and Policy Control to make 

sure that a certain file transfer service cannot be accessed through both HTTP and 

HTTPS protocols. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Create app patrol profile  

Go to Security Service > App patrol > Profile management,  and click Add to create 

profile  

 

Click add to add application in this profile.  
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Search Google Documents(aka Google Drive) , and  select this Application.  

Action set to Drop, and click Add.  

 

Set Up SSL Inspection on the FLEX 

In the FLEX, go to Security Service > SS L inspection > profile  > Profile Management , and 

click Add to create profile  
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Type profile Name, and select the CA  Certificate to be the certificate us ed in this 

profile.  Leave other actions as default settings.  

 

 

Apply profile to security policy  

Go to Security Policy > Policy control. Edit LAN_Outgoing , and scroll down to profile 

section.  

Select Application Patrol,  and SSL Inspection.  
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Export Certificate from FLEX and import to Lan hosts  

When SSL inspection is enabled and an access website does not trust the FLEX 

certificate, the browser will display a warning page of security certificate problems.  

Go to System > Certificate > My Certificates  to export default certificate from FLEX.  

 

Click Export Certificate  to export certificate file, and Save default certificate as 

default .crt  file to Windows OS.  

 

 

In Windows  Start Menu > Search Box , type MMC and press Enter. 
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In the mmc console window, click  File > Add/Remove Snap -in...  

 

 

In the Available snap -ins, select the Certificates  and click Add  button. Select Computer 

account  > Local Computer . Then, click Finished and OK to close the Snap -ins window.  
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In the mmc console window, open the Certificates (Local Computer) > Trusted Root 

Certification Authorities, right click  Certificate > All Tasks > Importé 

 

 

Click  Next . Then, Browse..., and  locate the default .crt  file you downloaded earlier. Then,  

click Next . 
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Select  Place all certificates in the following store  and then click Browse and find Trusted 

Root Certification Authorities.  Click Next , then click  Finish. 

 

 

Test the Result 

Access to Google drive  from Lan host to verify if it is block ed by firewall Application 

patrol.   

Go to Log & Report > Log/Events and select Application Patrol to check the logs.  
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How to Block the Spotify Music Streaming Service  
 

This is an example of using a FLEX UTM App Patrol Profile in a Security Policy to b lock the 

Spotify Music Streaming Service. You can use Application Patrol and Policy Control to 

ensure that the Spotify Music Streaming Service cannot be accessed on the LAN.  

 

 

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Create a App Patrol profile  

Go to Security Service > App patrol > Pr ofile management,  and click Add to create 

profile . 

 

Click add to add application in this profile.  

 

Search Spotify, and select this Application. Action set to Drop, and click Add.  
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Apply profile to security policy  

Go to Security Policy > Policy control. Edit LAN_Outgoing , and scroll down to profile 

section.  

Apply Application Patrol profile to Security policy.  

 

 

Test the Result 

Access to Spotify from Lan host to verify if it is blocked by firewall Application patrol.   

Go to Log & Report > Log/Events and select Application Patrol to check the logs.  
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How does Anti -Malware Work  
 

There are many viruses exist on the internet. And it may auto -downloaded on 

unexpected situation when you surfing between websites. The Anti -Malware is a good 

choose to protecti ng your computer to downloads unsafe application or files.  
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Enable Anti -Malware function to protecting your traffic  

Go to Security Service > Anti -Malware . Turn on this feature . Select  Collect Statistics and 

Scan and detect EICAR test virus .  

 

Select Destroy infected file and log in Actions When Matched  
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Test the Result 

Download EIACR file from a LAN host to verify if Anti -malware works for detection.  

Go to Log & Report > Log/Events and select Anti Malware to check the logs.  

 

Go to Sec urity Statistics > Anti -Malware  to check summary of all events.  
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How to Detect and Prevent TCP Port Scanning with DoS 

Prevention                     

This is an example of using a USG Flex H DoS Prevention  Profile to protect against 

anomalies based on violations of protocol standards (RFCs Requests for Comments) 

and abnormal traffic flows such as port scans.  

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: All  network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 

1.10). 
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Set Up the DoS Prevention  

In the USG Flex H, go to Security Policy > Dos Prevention   > Add  a profile . Configure a 

Name for you to identify the profile such as òDoS_Preventionó. Configure the Scan 

Detection  and Flood Detection  to block when the Dos prevention events were 

detected.   
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Set Up the DoS Prevention Policy  

In the USG Flex H, go to Security Policy > Dos  Prevention >  DoS Prevention Policy  

Configure a Name for you to identify the policy such as òDoS_Preventionó. Configure 

the From and Anomaly Profile  to block when the DoS prevention events were detected.   

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


































































































































































































































































































