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Chapter 1 -  VPN 

How to Configure Site - to -site IPSec VPN Where the Peer has a 
Static IP Address  
 
This example shows how to use the VPN Setup Wizard to create a site - to-site VPN with the 

Peer has a Static IP Address. The example instructs how to configure the VPN tunnel  

between each site. When the VPN tunnel is configured, each site can be accessed securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site - to-

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next . 
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Nex t  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP address of the network connected to the gateway and 

Remote Subnet to be the IP address of the network connected to the peer gateway.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for Branch  

VPN >  Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site - to-

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP ad dress of the network connected to the gateway and 

Remote Subnet to be the IP address of the network connected to the peer gateway.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a su mmary of the VPN tunnel. You can Edit it if you want to modify.  
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Test IPSec VPN Tunnel  

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1 

 

VPN Status > IPSec VPN  

Verify the IPSec VPN status and do the Connectivity Check  
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How to Con figure Site - to -site IPSec VPN Where the Peer has a 
Dynamic IP Address  
 
This example shows how to use the VPN Setup Wizard to create a site - to-site VPN with the 

Peer has a Dynamic IP Address. The example instructs how to configure the VPN tunnel 

between eac h site. When the VPN tunnel is configured, each site can be accessed securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Custom. 

Click Next . 

 
 

VPN > Site to Site VPN  

Type My Address and select Peer Gateway Address as Dynamic Address. Type a secure 

Pre-shared key.  
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Scroll down to find the Phase2 setting. Type Local and Remote Subnet and select 

Responder Only. Then click save change.  
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Set up IPSec VPN Tunnel for Branch  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Custom. 

Click Next.  

 
 
VPN > Site to Site VPN  

Type My Address as 0.0.0.0 and type Peer Gateway Addres s. Type a secure Pre -shared 

key. 
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Scroll down to find the Phase2 setting, type Local and Remote Subnet. Then click save 

change.  
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Test IPSec VPN Tunnel  

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1 

 

VPN Status > IPSec VPN  

Verify the IPSec VPN status and do the Connectivity Check  
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How to Configure IPSec Site to Site VPN while one Site is 
behind a NAT router  
 
This example shows how to use the VPN Setup Wizard to create a IPSec Site to Site VPN 

tunnel between USG FLEX H device s. The example instructs how to configure the VPN 

tunnel between each site while one Site is behind a NAT router. When the IPSec Site to Site 

VPN tunnel is configured, each site can be accessed securely.  

 

 

 

 

 

 

 

 

 

 

 

Note: Please ensure that you have NAT mapping UDP port 4500 to USG  FLEX H 

device.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the Behind NAT to the 

Remote Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP address of the network connect ed to the gateway and Remote 

Subnet to be the IP address of the network connected to the peer gateway.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for Branch  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the Behind NAT to the 

Local Site. Click Next.  
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VPN > Sit e to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  > Policy & Routing   

Set Local Subnet to be the IP address of the network connect ed to the gateway and 

Remote Subnet to be the IP address of the network connected to the peer gateway.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Copyright ©  2025 Zyxel and/or its affiliates. All rights reserved.  32 
 

www.zyxel.com  

VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to S ite VPN > Scenario > Network > Authentication  > Policy & Routing  > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to modify.  
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Test IPSec VPN Tunnel  

Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1 

 

VPN Status > IPSec VPN  

Verify the IPSec VPN status and do the Connectivity Check  
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How to Configure Remote Access VPN with Zyxel VPN Client  

This example shows how to setup Remote Access VPN on USG FLEX H and Zyxel VPN 

Client. The example inst ructs how to implement Remote Access VPN by SSLVPN and IPSec 

VPN. 
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Before Begin  

User & Authentication > User/Group > User  

Create local user for remote access authentication.  
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Download and install the new TGB Client  

 
 
Set up SSL VPN  
VPN > SSL VPN 

Select the incoming interface, the default port is 10443. And up to your requirement to 

select Full Tunnel or Split Tunnel. And we now support OpenVPN config file.  

For example: We pick up Split Tunnel and allows to access 192.168.100.0/24  
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The default Address Pool is 192.168.51.0/24 and select the User who can access SSL VPN.  

 
 

Set up IKEv2 VPN  
VPN > IPSec VPN > Remote Access VPN  

Select the incoming interface. And up to your requirement to select Full Tunnel or Split 

Tunnel.  

For example: We pick up Split Tunnel and allows to access 192.168.100.0/24  
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The default Address Pool is 192.168.50.0/24 and select the User who can access IKEv2 

VPN. 

 

Set up Remote Access on TGB Client  

Ǚ˜ʤἋ̓ʤХἋǙË^Ἃf̞˯ʤ̓φἋ̼ʤΡːʤἋǋǋŗἋȆƵŪἋȹ̓ʓἋăō|СᴝἋȆƵŪᶼἋȖ͔ϠἋʓ͔̓ᶩt need additional software for 

each other.  
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Input the Gateway Address, Username and password to fetch configuration file.  
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You will obtain IKEv2 as well as SSLVPN settings.  
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Test SSLVPN Tunnel on TGB Client  

Riː ˜φἋʈ̞˯ʈ̕Ἃφ˜ʤἋΘΡ͔˅˯̞ʤἋȹ̓ʓἋᶬſΘʤ̓ἋǙϠ̓̓ʤ̞ᶭἋȹ̓ʓἋ̞͔ːἋ˯̓ᶼ 

You will see the profile being green and can access internal resource now.  
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Test IKEv2 Tunnel on TGB Client  

ƾ˯ː˜φἋʈ̞˯ʈ̕Ἃφ˜ʤἋΘΡ͔˅˯̞ʤἋȹ̓ʓἋᶬſΘʤ̓ἋǙϠ̓̓ʤ̞ᶭἋȹ̓ʓἋ̞͔ːἋ˯̓ᶼ 

You will see the profile b eing green and can access internal resource now.  

 

Test IKEv2 Tunnel on Windows Client  

Download Windows VPN configuration script  
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Perform the windows bat file and input credentials.  
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VPN is connected and can access internal resource.  

 

Test IKEv2 Tunnel on iOS Client  

Download iOS/macOS VPN configuration script.  

 

Send the script to Device.  
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Settings > Profile Downloaded  
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Press Install.  

 

Enter Username and Password.  
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Now, it can connect.  
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Test IKEv2 Tunnel on Android Client  

Download Android(strongSwan) VPN configuration script.  

 

Download strongSwan from Google Play Store.  
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Send the script to device then Install and Import strongSwan profile.  
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VPN is connected.  
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Test OpenVPN  

VPN > SSL VPN 
We now suppo rt OpenVPN config file, Click Download to obtain the ovpn file.  
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Import the config file.  VPN is connected.  
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How to Configure Site - to -site IPSec VPN between ZLD and uOS 
device  
 
This example shows how to use the VPN Setup Wizard t o create a site - to-site VPN with the 

Peer gateway is ZLD device. The example instructs how to configure the VPN tunnel 

between each site. When the VPN tunnel is configured, each site can be accessed securely.  
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Set up IPSec VPN Tunnel for uOS  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site - to-

Site. Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Local Subnet to be the IP addr ess of the network connected to USG FLEX H and Remote 

Subnet to be the IP address of the network connected to the peer ZyWALL.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  > 

Summary  

The screen provides a sum mary of the VPN tunnel. You can Edit it if you want to modify.  
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Set up IPSec VPN Tunnel for ZLD  

VPN > IPSec VPN > VPN Gateway  

Select the WAN interface and type the Peer Gateway Address.  
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Type Pre -shared Key. The default proposal whic ˜ἋʈΡʤȹφʤʓἋʀгἋХ˯ыȹΡʓἋ˯εἋᶬ|̓ʈΡгΘφ˯͔̓ᶿ |ǋᴜᴝᴥᶻἋ

Ϡφ˜ʤ̓φ˯ʈȹφ˯͔̓ᶿǋß ᴜᶻἋōʤгἋËΡ͔ϠΘᶿqßᴝᶭᶼἋǙ˜͔εʤἋȹΡʤἋφ˜ʤἋεȹ̼ʤἋȹεἋϠſǋᶼ 
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VPN > IPSec VPN > VPN Connection  

Select VPN Gateway and set Local Subnet to be the IP address of the network connected 

to be Zy WALL and Remote Subnet to be the IP address of the network connected to the 

peer USG FLEX H. 
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Ǚ˜ʤἋʓʤ˅ȹϠ̞φἋΘΡ͔Θ͔εȹ̞ἋХ˜˯ʈ˜ἋʈΡʤȹφʤʓἋʀгἋХ˯ыȹΡʓἋ˯εἋᶬ|̓ʈΡгΘφ˯͔̓ᶿἋ |ǋᴜᴝᴥᶻἋ Ϡφ˜ʤ̓φ˯ʈȹφ˯͔̓ᶿἋǋß ᴜᶻἋ

ōʤгἋËΡ͔ϠΘᶿἋqßᴝᶭᶼἋǙ˜͔εʤἋȹΡʤἋφ˜ʤἋεȹ̼ʤἋȹεἋϠſǋᶼ 
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Test IPSec VPN Tunnel  

Ping the PC that is connected to ZLD device  

Win 11 > cmd > ping 192.168.2.34  

 

VPN Status > IPSec VPN  

Verify the IPSec VPN status and do the Connectivity Check  
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How to Configure Route -Based VPN  

This example shows how  to use the VPN Setup Wizard to create a site - to-site VPN with the 

Peer has a Static IP Address. The example instructs how to configure the VPN tunnel 

between each site. When the VPN tunnel is configured, each site can be accessed securely.  
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Set up IPSec VPN Tunnel for HQ  

VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site - to-Site. 

Click Next . 
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VPN > Site to Site VPN > Scenario > Network  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing  

Set Type to Route -Based and configure the Remote Subnet.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 

Summary  

The screen provides a summary of the VPN tunnel. You can Edit it if you want to mod ify.  
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Set up IPSec VPN Tunnel for Branch  
VPN > Site to Site VPN > Scenario  

Type the VPN name used to identify this VPN connection. Select the type to the Site - to-Site. 

Click Next . 
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VPN > Site to Site VPN > Scenario > Netw ork  

Configure My Address and Peer Gateway Address. Click Next.  
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VPN > Site to Site VPN > Scenario > Network > Authentication  

Type a secure Pre -Shared Key. Click Next  
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VPN > Site to Site VPN > Scenario > Network > Au thentication > Policy & Routing  

Set Type to Route -Based and Remote Subnet.  
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VPN > Site to Site VPN > Scenario > Network > Authentication > Policy & Routing > 
Summary  
The screen provides a summary of the VPN tunnel. You can Edit it if yo u want to modify.  
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Test IPSec VPN Tunnel  

VPN Status > IPSec VPN  

Verify the IPSec VPN status.  

 
 
Ping the PC in Branch Office  

Win 11 > cmd > ping 192.168.160.1 
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How to Use Tailscale  
 

ȉ˜ȹφᶩεἋǙȹ˯̞εʈȹ̞ʤᵵ 

Tailscale is a secure, peer - to-peer VPN solution that simplifies connecting devices over the 

internet. Unlike traditional VPNs, Tailscale establishes direct connections between devices 

without requiring complex firewall configurations or static IP addresses. It uses a mesh 

network topology , allowing every device to communicate directly with every other device 

securely.  

 

Start to Tailscale and implement on Firewall  

1. Please refer TailScale KB to create an account and start.  

2. ŪȹС˯ːȹφʤἋφ͔Ἃᶬǋʤφtings -> Personal Settings -᷾ἋōʤгεᶭἋȹ̓ʓἋᶬËʤ̓ʤΡȹφʤἋȹϠφ˜Ἃ̕ʤгᶭᶼ 

 

 

 

 

 

 

 

 

https://tailscale.com/kb/1017/install
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3. Ë˯СʤἋȹἋqʤεʈΡ˯Θφ˯͔̓ἋŪȹ̼ʤἋȹεἋг͔ϠἋХȹ̓φἋȹ̓ʓἋʓ˯εȹʀ̞ʤἋᶬƾʤϠεȹʀ̞ʤᶭἋʓϠʤἋφ͔ἋεʤʈϠΡ˯φгἋΡʤȹἐ͔Ἃφ˜ʤ̓Ἃ

ʈ̞˯ʈ̕ἋᶬËʤ̓ʤΡȹφʤἋ̕ʤгᶭᶼ 
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Copy the key.  

 

4. ŗ͔ː˯̓ἋÇ˯ΡʤХȹ̞̞Ἃȹ̓ʓἋ̓ȹС˯ːȹφʤἋφ͔ἋᶬȆƵŪἋ-᷾ἋǙȹ˯̞εʈȹ̞ʤᶭᶻἋΘȹεφʤἋφ͔Ἃφ˜ʤἋᶬ Ϡφ˜Ἃōʤгεᶭᶼ 

 

 
 
 
Note:  
 

 

 

 

 

 

 

Note:  

· When you want to change the key, please click Logout.  

· You can choose the zone by yourself. We recommend using Tailscale zone 

for some predefined rules . 
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5. Go back to the Tailscale admin page. You will see the Firewall device.  

 

f̞˯ʈ̕Ἃᶬq˯εȹʀ̞ʤἋ̕ʤгἋʤЮΘ˯ΡгᶭἋ˅͔ΡἋȹ̞̞Ἃʈ̞˯ʤ̓φἋφ͔ἋΘΡʤСʤ̓φἋ̞͔εφἋʈ͔̓̓ʤʈφ˯͔̓ἋХ˜˯̞ʤἋʤЮΘ˯Ρʤᶼ 
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Scenario  

We have two subnets, 192.168.168. 0/24 and 192.168.160.0/24, which are located behind 

firewalls. Both the firewalls and the Client A are part of the Tailscale VPN network. The 

objectives are as follows:  
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Case1: Allow Client A to access the 192.168.168.0/24 and 192.168.160.0/24 subnets  

1. Advertised 192.168.168.0/24 in Firewall A.  

 
2. Advertised 192.168.160.0/24 in Firewall B.  

 

 

 

 

 

 

 



 

Copyright ©  2025 Zyxel and/or its affiliates. All rights reserved.  83 
 

www.zyxel.com  

3. Ensure Both subnets have been approved from Tailscale portal.  

 

Test the Result  

Now, Client A know how to route traffic and able to access 192.168.168.1  and 192.168.160.1. 
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Case 2: Allow Client A to access internet through Firewall  

1. Ǚȹ̕ʤἋÇ˯ΡʤХȹ̞̞Ἃ ἋȹεἋʤЮȹ̼Θ̞ʤᶼἋ|̓ȹʀ̞ʤἋᶬ|Ю˯φἋŪ͔ʓʤᶭἋȹ̓ʓἋᶬqʤ˅ȹϠ̞φἋǋŪ Ǚᶭᶼ 
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2. Ensure the Exit -Node have been enabled from Tailscale portal.  
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3. Client A need to sel ect Firewall A as exit node.  

 

 

Test the Result  

The internet traffic will send to Firewall A.  
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Case3: The devices within the 192.168.168.0/24 and 192.168.160.0/24 subnets can 

communicate with each other  

Once you completed advertised Networks, you can communicate each other.  

 

Test the Result  

The ping test from Firewall A  

 

The ping test from Firewall B  
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How to use Ext -group user to connect Remote Access VPN  

Remote Access VPN now supports using external user groups for VPN accounts. This article  

will guide you through the setup process  

Before Begin  

Ȗ͔ϠἋȹ̞ΡʤȹʓгἋ˅͔̞̞͔ХʤʓἋǙ͔Θ˯ʈἋᶬß͔ХἋφ͔Ἃʈ͔̓˅˯ːϠΡʤἋƾʤ̼͔φʤἋ ʈʈʤεεἋȆƵŪἋХ˯φ˜ἋȮгЮʤ̞ἋȆƵŪἋf̞˯ʤ̓φᶭ 

as well as ᶬß͔ХἋφ͔ἋεʤφϠΘἋ qἋȹϠφ˜ʤ̓φ˯ʈȹφ˯͔̓ἋХ˯φ˜ἋŢ˯ʈΡ͔ε͔˅φἋ qᶭἋφ͔Ἃʈ͔̼Θ̞ʤφʤἋƾʤ̼͔φʤἋ ʈʈʤεεἋ 

and Authentication server set tings.  

User & Authentication > User/Group > User  

Create a user and select User type as ext -group -user. At this point, the group identifier will  

Automatically populate with the CN that has the group attribute.  
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VPN > SSL VPN 

Taking SSL VPN as an exampl e, User select the ext -group user you just created. And 

choosing AD authentication.  

 
 
 
 
 
 
 
 
 



 

Copyright ©  2025 Zyxel and/or its affiliates. All rights reserved.  90 
 

www.zyxel.com  

Test the Result  

VPN Status > SSL VPN > Remote Access VPN  

User within the group can successfully connect  
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Chapter 2 -  Security Service  

How to Block HTTPS Websites Using Content Filtering and SSL 

Inspection  

This is an example of using a FLEX Content Filtering, SSL Inspection and Security Policy to 

block access to malicious or not business - related websites.  

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Set Up Content Filter  

Go to Security Service > Content Filtering. Click Add to create a content filtering profile in 

Profile Management.  

 

Type profile name and enable log for block action in General Settings.  

 

Tick Streaming Media category in Managed Categories, and click Apply.  
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Set Up SSL Inspection  

In the FLEX, go to Security Service > SSL inspection > profile > Profile Management, and 

click Add to create profile  

 

Type profile Name, and select the CA Certificate to be the certificate used in this profile. 

Leave other a ctions as default settings.  

 

Click Apply to add SSL Inspection profile.  
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Set Up the Security Policy  

Go to Security Policy > Policy control. Edit LAN_Outgoing, and scroll down to profile 

section.  

Select Content Filtering, and SSL Inspection. Click Ap ply to save.  

 

Export Certificate from FLEX and Import it to Windows  
 
When SSL inspection is enabled and an access website does not trust the FLEX certificate, 

the browser will display a warning page of security certificate problems.  

Go to System > Certifi cate > My Certificates to export default certificate from FLEX.  

 
 
Click Export Certificate to export certificate file, and Save default certificate as default.crt 

file to Windows OS.  
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In Windows Start Menu > Search Box, type MMC and press Enter.  

 
In the mmc console window, click File > Add/Remove Snap - in...  

 
In the Available snap - ins, select the Certificates and click Add button. Select Computer 

account > Local Computer. Then, click Finished and OK to close the Snap - ins window.  
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In the mmc conso le window, open the Certificates (Local Computer) > Trusted Root 

fʤΡφ˯˅˯ʈȹφ˯͔̓Ἃ Ϡφ˜͔Ρ˯φ˯ʤεᶻἋΡ˯ː˜φἋʈ̞˯ʈ̕ἋfʤΡφ˯˅˯ʈȹφʤἋ᷾Ἃ ̞̞ἋǙȹε̕εἋ᷾Ἃă̼Θ͔Ρφᶽ 

 
Click Next. Then, Browse..., and locate the default.crt file you downloaded earlier. Then, 

click Next.  
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Select  Place all certificates in the following store and then click Browse and find Trusted 

Root Certification Authorities.  Click Next, then click  Finish. 
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Test the Result  

Using Web Browser to access the YouTube. The gateway will redirect you to a blocked 

page.  

 

Go to Log & Report > Log/Events and select Content Filtering to check the logs.  

 

 

 

 

 



 

Copyright ©  2025 Zyxel and/or its affiliates. All rights reserved.  99 
 

www.zyxel.com  

Go to Security Statistics > SSL Inspection > Summary. Traffic is inspected by SSL 

inspection.  

 

Go to Security Statistics > Content Filter to check summar y of all events.  
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How to Configure Content Filter with HTTPs Domain Filter                    

The Content Filter with HTTPs Domain Filter allows you to block HTTPs websites by 

category service. The filtering feature is based on over 100 categories that i s built in USG 

Flex H such as pornography, gambling, hacking, etc.  

When the user makes an HTTPS request, the information contains a Server Name 

Indication (SNI) extension fields in server FQDN. Using the SNI to query category from 

local cache then the clou d database, then take action when it matches the block category 

in the Content Filter profile.  

 

 

 

 

 

 

 

Note: All n etwork IP addresses and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 

1.10). 
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Set  Up the Content Filter  

Go to Security Service > Content Filtering > Profile Management   >  Add  a Content Filter 

profile . Configure a Name for you to identify the Content Filter profile such as 

ᶬǋ͔ʈ˯ȹ̞ḘŪʤφХ͔Ρ̕˯̓ːᶭᶼἋConfigure the Action  to block when the Content Filter detects events.   

  

Navigate  to Test Web Site Category  and type URL to test the category and click Query . 

 

 

 

 

 



 

Copyright ©  2025 Zyxel and/or its affiliates. All rights reserved.  102 
 

www.zyxel.com  

You will see the category  Ρʤʈ͔ΡʓʤʓἋ˯̓Ἃφ˜ʤἋʤЮφʤΡ̓ȹ̞Ἃʈ͔̓φʤ̓φἋ˅˯̞φʤΡἋεʤΡСʤΡᶩεἋʓȹφȹʀȹεʤἋ˅͔ΡἋʀ͔φ˜Ἃ

HTTP and HTTPS Domain you specified.  

 

Scroll to the Managed Categories section, and select categories in this section to control 

access to specific types of Internet content.  
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Set  Up the Security Policy  

Go to Security Policy > Policy Control  to configure a Name  for you to identify the Security 

Policy  profile. For From  and To  policies, select the direction of travel of packets to which 

the policy applies and apply the Profile  > Content Filter  Sɱocial_Networking ᶭἋ ͔̓Ἃφ˜˯εἋ

security policy.  
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Test Result  

Type the URL http:// www.facebook.com / or https:// www.  facebook.com / onto the browser 

and cann ot browse facebook.  

 

Navigate to Log & Report > Log / Events , you will see [alert] log of blocked messages.  

 

 

 

 

 

 

 

 

 

 

http://www.facebook.com/
http://www.youtube.com/
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How to Block Facebook Using a Content Filter Block List                     

This is an example of using USG Flex H UTM Profile in a Sec urity Policy to block access to 

a specific social network service. You can use Content Filter and Policy Control to make 

sure that a certain web page cannot be accessed through both HTTP and HTTPS 

protocols.  

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresse s and subnet masks are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 1.10).  
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Set  Up the Content Filter  

In the USG Flex H, go to Security Service > Content Filtering > Profile Management   >  

Add  a Content Filter profile . Configure a Name for you to identify the Content Filter profile 

εϠʈ˜ἋȹεἋᶬÇȹʈʤʀ͔͔̕Ḙ^̞͔ʈ̕ᶭᶼἋConfigure the Action  to block when the Content Filter detec ts 

events.   

  

 

Go to Block List  ȹ̓ʓἋφгΘʤἋǦƾŗἋᶬḜᶼ˅ȹʈʤʀ͔͔̕Ḝᶼʈ͔̼ᶭἋφ͔Ἃadd the URL that you want to block . 
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Set  Up the Security Policy  

Go to Security Policy > Policy Control  to configure a Name  for you to identify the Security 

Policy  profile. For From  and To  policies, select the direction of travel of packets to which 

the policy applies and apply the Profile > Content Filter  Fɱacebook_Block ᶭἋ͔̓Ἃφ˜˯εἋεʤʈϠΡ˯φгἋ

policy.  
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Test the  Result  

Type the URL http:// www.facebook.com / or https:// www.  facebook.com / onto the browser 

and cannot browse facebook.  

 

Go to Log & Report > Log / Events , you will see [alert] log of blocked messages.  

 

  

 

 

 

 

 

 

 

 

 

http://www.facebook.com/
http://www.youtube.com/
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How to block YouTube acce ss by Schedule                    

This is an example of using the USG Flex H to block access YouTube access by schedule. 

You can use Application Patrol and security policy with schedule settings to make sure 

that YouTube cannot be accessed in your network at a specific prohibited time. This 

article will guide you on how to deploy it.  

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: All network IP addresses and subnet masks  are used as examples in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 1.10).  
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Set  Up the Schedule  

Go to Object > Schedule > Recurring >  Add  Schedule Recurring Rule . Configure a Name 

for you to identify the Schedule Recurring Rul e. Specify the Day Time  hour and minute 

when the schedule begins and ends each day.   
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Create  the Application Patrol profile  

In the USG Flex H, go to  Security Service > App Patrol > General Settings > Application 

Management . To add an App Patr ͔̞ἋΘΡ͔˅˯̞ʤᶻἋʈ͔̓˅˯ːϠΡʤἋφ˜ʤἋΘΡ͔˅˯̞ʤἋ̓ȹ̼ʤἋȹ̓ʓἋεʤ̞ʤʈφἋᶬSearch 

Application ᶭᶼἋǙ˜ʤ̓Ἃʤ̓φʤΡἋφ˜ʤἋ̕ʤгХ͔ΡʓἋᶬг͔ϠφϠʀʤᶭἋφ͔ἋεʤȹΡʈ˜Ἃφ˜ʤἋ̕ʤг-related results and 

select all YouTube - related apps and click Add.  
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Set  Up the Security Policy  

Go to Object > Service  to add a  UDP 443 service object.   
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Go to Security Policy > Policy Control  to configure a Name  for you to identify the Security 

Policy  profile. For From  and To  policies, select the direction of travel of packets to which 

the policy applies. Select the service  QUIC_UDP443 and select the Schedule  that defines 

when the policy would be applied.  

ă̓Ἃφ˜˯εἋʤЮȹ̼Θ̞ʤᶻἋεʤ̞ʤʈφἋᶬȖ͔ϠφϠʀʤḘ^̞͔ʈ̕ʤʓḘǙ˯̼ʤᶭᶼἋ 
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Add another security policy to block YouTube by schedule. To configure a Name  and the 

From , To traffic direct ion. Select the Schedule  that defines when the policy would be 

applied. Finally, to scroll down the Profile , check Application Patrol  and select a profile 

from the list box. In this example, Schedule : Youtube_Block_Time; Application Patrol : 

Youtube.  
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Ǚ˜ʤ̓Ἃː͔Ἃʀȹʈ̕Ἃφ͔Ἃφ˜ʤἋεʤʈϠΡ˯φгἋΘ͔̞˯ʈгἋΘȹːʤἋȹ̓ʓἋ̼͔СʤἋφ˜ʤἋεʤʈϠΡ˯φгἋΘΡ˯͔Ρ˯φгἋ͔˅Ἃʀ̞͔ʈ̕ἋǦqƵἋᴠᴠᴟἋ

˯εἋ˜˯ː˜ʤΡἋφ˜ȹ̓Ἃʀ̞͔ʈ̕ἋȖ͔ϠǙϠʀʤἋʀгἋεʈ˜ʤʓϠ̞ʤᶼ 
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Test the  Result  

Type the URL http:// www.youtube.com / or https:// www.youtube.com / onto the browser 

and cannot browse YouTube.  

 

Open the YouTube APP on the phone and cannot access to YouTube.  

 

 

http://www.youtube.com/
http://www.youtube.com/
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Go to Log & Report > Log / Events , you will see [alert] log of blocked mess ages.  
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How to Control Access to Google Drive  
 
This is an example of using a FLEX UTM Profile in a Security Policy to block access to a 

specific file transfer service. You can use Application Patrol and Policy Control to make 

sure that a c ertain file transfer service cannot be accessed through both HTTP and HTTPS 

protocols.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examp les in this 

article. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Create app patrol profile  

Go to Security Service > App patrol > Profile management, and click Add to create profile  

 
Click add to add application in thi s profile.  
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Search Google Documents(aka Google Drive) , and select this Application.  

Action set to Drop, and click Add.  

 

Set Up SSL Inspection on the FLEX  

In the FLEX, go to Security Service > SSL inspection > profile > Profile Management, and 

click Add to create profile  
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Type profile Name, and select the CA Certificate to be the certificate used in this profile. 

Leave other actions as default settings.  

 

 

Apply profile to security policy  

Go to Security Policy > Policy control. Edit LAN_ Outgoing, and scroll down to profile 

section.  

Select Application Patrol, and SSL Inspection.  
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Export Certificate from FLEX and import to Lan hosts  

When SSL inspection is enabled and an access website does not trust the FLEX certificate, 

the browser w ill display a warning page of security certificate problems.  

Go to System > Certificate > My Certificates to export default certificate from FLEX.  

 
Click Export Certificate to export certificate file, and Save default certificate as default.crt 

file to W indows OS.  

 
 
In Windows Start Menu > Search Box, type MMC and press Enter.  
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In the mmc console window, click File > Add/Remove Snap - in...  

 
 
In the Available snap - ins, select the Certificates and click Add button. Select Computer 

account > Local  Computer. Then, click Finished and OK to close the Snap - ins window.  
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In the mmc console window, open the Certificates (Local Computer) > Trusted Root 

fʤΡφ˯˅˯ʈȹφ˯͔̓Ἃ Ϡφ˜͔Ρ˯φ˯ʤεᶻἋΡ˯ː˜φἋʈ̞˯ʈ̕ἋfʤΡφ˯˅˯ʈȹφʤἋ᷾Ἃ ̞̞ἋǙȹε̕εἋ᷾Ἃă̼Θ͔Ρφᶽ 

 
 

Click Next. Then,  Browse..., and locate the default.crt file you downloaded earlier. Then, 

click Next.  
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Select  Place all certificates in the following store and then click Browse and find Trusted 

Root Certification Authorities.  Click Next, then click  Finish. 

 

 

Test  the Result  

Access to Google drive from Lan host to verify if it is blocked by firewall Application patrol.  

Go to Log & Report > Log/Events and select Application Patrol to check the logs.  
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How to Block the Spotify Music Streaming Service  
 

This is an  example of using a FLEX UTM App Patrol Profile in a Security Policy to block the 

Spotify Music Streaming Service. You can use Application Patrol and Policy Control to 

ensure that the Spotify Music Streaming Service cannot be accessed on the LAN.  

 

 

 

 

 

 

 

 

 

 

 

 

Note: All network IP addresses and subnet masks are used as examples in this 

arti cle. Please replace them with your actual network IP addresses and subnet 

masks. This example was  tested using USG FLEX 200H (Firmware Version: uOS 1.10).  
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Create a App Patrol profile  

Go to Security Service > App patrol > Profile management, and click Add to create profile.  

 
Click add to add application in this profile.  

 
Search Spotify, and select this Application. Action set to Drop, and click Add.  
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Apply profile to security policy  

Go to Security Policy > Policy control. Edit LAN_Outgoing, and scroll down to profile 

section.  

Apply Application Patrol profile to Security policy.  

 

 

Test the Result  

Access to Spotify from Lan host to verify if it is blo cked by firewall Application patrol.  

Go to Log & Report > Log/Events and select Application Patrol to check the logs.  
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How does Anti -Malware Work  
 
There are many viruses exist on the internet  and it may be auto-downloaded on 

unexpected situation when  you surfing between websites. The Anti -Malware is a good 

choose to protecting your computer to downloads unsafe application or files.  
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Enable Anti -Malware function to protecting your traffic  

Go to Security Service > Anti -Malware. Turn on this  feature. Select Collect Statistics and 

Scan and detect EICAR test virus.  

 

Select Destroy infected file and log in Actions When Matched 
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Test the Result  

Download EIACR file from a LAN host to verify if Anti -malware works for detection.  

Go to Log  & Report > Log/Events and select Anti Malware to check the logs.  

 

Go to Security Statistics > Anti -Malware to check summary of all events.  
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How to Detect and Prevent TCP Port Scanning with DoS 

Prevention                     

This is an example of usi ng a USG Flex H DoS Prevention  Profile to protect against 

anomalies based on violations of protocol standards (RFCs Requests for Comments) and 

abnormal traffic flows such as port scans.  

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: All network IP addresses and subnet masks are used as examples in this 

article. Please repl ace them with your actual network IP addresses and subnet 

masks. This example was tested using USG FLEX 500H (Firmware Version: uOS 

1.10). 
































































































































































































































































































































































































